Mettre son PHP à jour c'est garder une sécurité constante sur son site e-commerce

Le PHP - la base des sites Internet

Le PHP langage de programmation libre, principalement utilisé pour produire des pages Webs dynamiques. C'est un langage de base dans la création de sites Internet, et se trouve donc aussi dans la majorité des sites e-commerce.

Un langage qui évolue

La communauté PHP travaille constamment à faire évoluer ce langage pour rester à la pointe, corriger des bugs et apporter des solutions aux nouvelles failles de sécurité. Il est donc impératif de se tenir au courant des versions supportées et des nouvelles versions disponibles, pour garantir à votre commerce une sécurité sans faille.
Voici les versions supportées actuellement par la communauté de PHP.net


Les codes couleurs indiquent le support actif (vert), le support de sécurité critique uniquement (orange) et l'arrêt de support (rouge).
*tableau en date de juillet 2018. Retrouvez le tableau actualisé ici: http://php.net/supported-versions.php ou ici http://php.net/eol.php

Savez-vous quelle version PHP votre site e-commerce utilise ?

Pour connaitre la version PHP que votre site utilise, vous pouvez vous tourner vers votre hébergeur (OVH, Ex2, Nuxit, 1&1, Ikoula, Likuid....) ou utiliser la méthode suivante:

  • Créer un fichier texte à la racine de votre site nommé info.php par exemple.
  • Copier le code ci-dessous à l’intérieur du fichier et enregistrer :
<?php
phpinfo();
?>
  • Depuis le navigateur, accéder à la page www.url-de-votre-site.com/info.php pour voir l’information.
  • Supprimer le fichier info.php une fois que vous avez l’information.

Et le paiement ?

Avec la plateforme de paiement PayZen, vous êtes assuré de bénéficier de plugins qui supportent certaines versions obsolètes de PHP (jusqu'à PHP 5.3). Vos paiements sont en sécurité. Cependant, votre site peut être ouvert à d'autres dangers critiques de sécurité hors de notre portée. 
Nous vous conseillons de mettre à jour votre PHP à la version PHP 7.1 ou plus. La durée de vie d’une version PHP est d’environ 2 ans et vous garantit une meilleure sécurité et compatibilité avec vos différents services autour de votre site e-commerce. Les dernières versions de nos plugins sont compatible avec les dernières versions de PHP et peuvent également vous permettre d'avoir accès à de nouvelles fonctionnalités.Toutes les infos ici: PayZen.io

AVANT de mettre à jour votre plugin

Avant de mettre à jour le plugin de paiement, vérifiez que le plugin choisi est bien compatible avec la version PHP de votre site (surtout si vous utilisez une version PHP inférieure à 5.3).
Dans le cas contraire, cela peut causer des dysfonctionnements de votre site, jusqu’à ce que vous rebasculiez sur une ancienne version de plugin compatible ou que vous mettiez à jour votre version PHP.



Commentaires